题 我需要哪些Prosody模块来支持对话?


我正在配置一个Prosody服务器,用于支持移动客户端 OMEMO。我选了 对话 作为参考客户,因为我熟悉它。我需要安装什么Prosody模块来支持它?


7
2018-03-01 12:59






答案:


对话提供了需要服务器端支持的XEP列表,转载如下,链接到相应的Prosody 0.9.x模块。

对于加密群聊(OMEMO支持),您只需要 mod_pep 和 mod_roster。其他模块考虑了OMEMO上下文(例如,共享文件)和环境(例如,移动客户端,防火墙后面的客户端)中的附加功能。

笔记:

韵律0.10注释:

参考文献:


10
2018-03-01 12:59



您错过了“cloud_notify”(XEP_0357),这是对话所必需的。 - Mirko
@Mirko更新了,谢谢 - d3vid
要记住的一个问题是 mod_pep数据目前不是持久的,这可能导致 服务器重启后无法向脱机参与者发送消息,因为没有必要的密钥。关于相关问题的工作已于2017年4月“开始”,但实施持久性的代码尚未提交,此时似乎可能无法进入0.10。 - GreenReaper